Scheduled for November 09, 2024 at 6:20 PM – 6:50 PM
Affects
Server
Under maintenance from 6:20 PM to 6:50 PM
Completed
November 09, 2024 at 6:50 PMCompleted
November 09, 2024 at 6:50 PMMaintenance has completed successfully
In progress
November 09, 2024 at 6:20 PMIn progress
November 09, 2024 at 6:20 PMMaintenance is now in progress
Planned
November 09, 2024 at 6:20 PMPlanned
November 09, 2024 at 6:20 PMSome of the Bloxlink bindings will not work while the maintenance is in process. We are sorry for the inconviniece caused. Please DO NOT use the /update role as it may cause you to lose all of your discord roles, until we notice.